never seen this before...

Outboard Related Only
fleetwin
Posts: 2378
Joined: Mon Mar 09, 2015 4:27 pm
Location: Rhode Island

never seen this before...

Postby fleetwin » Sun Jun 10, 2018 10:16 pm

https://www.ebay.com/itm/1994-Evinrude- ... Sw7kVbHU3v

Auction says this mag plate is from a 94 48spl...But, sure don't recognize those ignition parts...Looks like an old driver coil along with some sort of crazy sensor set up....
After market replacement pieces??

Dan in TN
Posts: 1025
Joined: Mon Mar 09, 2015 3:58 pm
Location: Smyrna, TN

Re: never seen this before...

Postby Dan in TN » Sun Jun 10, 2018 10:56 pm

I think if you look at the parts break down you will see this is a CDI charge coil replacement. They just sell the coil without laminates.
I looked thinking maybe it was replacement for UFI, but I guess it was long gone by then. I don't remember the plate with the sensor under it? Anyway if the charge coil is CDI then I guess some of the other stuff could be too or I have just forgot how it looked.

Dan in TN


fleetwin
Posts: 2378
Joined: Mon Mar 09, 2015 4:27 pm
Location: Rhode Island

Re: never seen this before...

Postby fleetwin » Tue Jun 12, 2018 9:10 am

Yeah, was wondering if this is one of those UFI-CDII conversion kits...The charge coil with its missing potting/laminates fooled me as well...I guess that metal mounting bracket is necessary because there were no mounting bosses for the sensor on the UFI mag plates...

Dan in TN
Posts: 1025
Joined: Mon Mar 09, 2015 3:58 pm
Location: Smyrna, TN

Re: never seen this before...

Postby Dan in TN » Tue Jun 12, 2018 11:16 am

CDI doesn't pot their windings/laminates except for ignition coils. Says they run cooler that way. I always wondered about salt water corrosion? Anyway when you see a stator or driver coil that is open you usually know it's CDI. I'm still not sure about the plate that is mounting the sensor? I thought UFI was gone by then.

Dan in TN

fleetwin
Posts: 2378
Joined: Mon Mar 09, 2015 4:27 pm
Location: Rhode Island

Re: never seen this before...

Postby fleetwin » Tue Jun 12, 2018 1:56 pm

Maybe it is from a 93 model, they still used UFI in 93...

Dan in TN
Posts: 1025
Joined: Mon Mar 09, 2015 3:58 pm
Location: Smyrna, TN

Re: never seen this before...

Postby Dan in TN » Tue Jun 12, 2018 2:12 pm

There it is fleetwin. 1993 40hp. CDI kit #113-4489. Even says this side up with sensor coil underneath. That answers that. Check it out.

http://www.marineengine.com/parts/image ... 3-4489.jpg


Dan in TN


fleetwin
Posts: 2378
Joined: Mon Mar 09, 2015 4:27 pm
Location: Rhode Island

Re: never seen this before...

Postby fleetwin » Tue Jun 12, 2018 5:53 pm

OK, well now I know what these conversion kits look like...D

User avatar
Garry in Tampa
Posts: 2735
Joined: Mon Mar 09, 2015 2:32 pm
Location: Florida

Re: never seen this before...

Postby Garry in Tampa » Tue Jun 12, 2018 8:44 pm

Fastenating - much too new an antique for me . . . :roll:

93 Stator Kit.png
93 Stator Kit.png (541.07 KiB) Viewed 659 times

94 Stator assy.png
94 Stator assy.png (1.47 MiB) Viewed 659 times

Image
Living my dream because Reality is too expensive . . .


Return to “Ask A Member”

Who is online

Users browsing this forum: Fisherman6, flyingvranch, Google [Bot], Mumbles and 14 guests