’56 Fleetwin Disassembly

Home Forum Ask A Member ’56 Fleetwin Disassembly

Viewing 4 posts - 1 through 4 (of 4 total)
  • Avatar
    marvk


    Replies: 56
    Topics: 12
    #1412

    Had some time to start disassembling my Fleetwin tonight. Did a little cleaning and removed the powerhead for the normal maintainence. First thing I noticed, the o-ring in the carbon seal was missing. 😯 The carbon seal itself looks OK, the spring was worn somewhat on both ends, but still intact. Top of the driveshaft and splines are clean. I’m hoping it wasn’t run to long without the o-ring.

    From what I can see through the exhaust ports, and plug holes, there doesn’t appear to be any rust on the pistons or walls, they look clean and not scored.

    Tomorrow the lower gets pulled. I have a new prop seal and o-ring to replace, along with a new impeller, water pipe grommet, seal and bushing for the shift rod, and shifter o-ring.

    Avatar
    marvk


    Replies: 56
    Topics: 12
    #15382

    While I’m thinking of it, Is this inlet plate oriented correctly? All my other OMC’s are reversed from this one. I thought I read somewhere that this is the correct way it should be mounted. Reason being, to help cooling when running in reverse.

    Mumbles
    Mumbles

    Canada Member - 2 Years
    Replies: 4303
    Topics: 428
    #15383

    It goes the other way, same as the ones on your other motors. Mounted this way, at high speed it can draw water out of the pumps intake passage instead of scooping it in. Operating the motor in reverse shouldn’t make the boat go fast enough to make any difference.

    Avatar
    marvk


    Replies: 56
    Topics: 12
    #15411

    Thanks for the explanation. 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.